Ce site utilise des cookies pour assurer une future reconnaissance de votre compte et pour votre confort de navigation. En poursuivant votre navigation, vous en acceptez l'utilisation.

Modules Shop › Rétro-compatibilité des modules prestashop 1.4 pour 1.5

Modules, addons et widgets pour booster votre e-business sur Wordpress et PrestaShop.

08 Déc

Rétro-compatibilité des modules prestashop 1.4 pour 1.5

publié 8 décembre 2012 fichier sous PrestaShop 1-5

Beaucoup d’entres vous rencontre des problèmes d’incompatibilités sur les modules installés en prestashop 1.4 pour les nouvelles versions en 1.5

Cette nouvelle version utilise « Le Context » qui permet d’accéder à n’importe quel objet du système.

voici quelque petites astuces afin d’éviter le « is deprecated in prestashop 1.5.2″…

 

remplacer

$cookie->isLogged();

par

$this->context->customer->isLogged();

 

remplacer

Tools::addJS(...ici rien ne change...);

par

$this->context->controller->addJS(...ici rien ne change...);

 

remplacer

$smarty->assign(array(...ici rien ne change...));

par

$this->context->smarty->assign(array(...ici rien ne change...));

 

bon correctif !

 

catégories: PrestaShop 1-5

balises: , ,